aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorWilliam L. DeRieux IV <williamderieux@gmail.com>2021-12-28 08:06:24 -0500
committerGitHub <noreply@github.com>2021-12-28 14:06:24 +0100
commitcc64a0405ae0e4025f0b18be3bd0d813cb36fea0 (patch)
tree03f1114bf2f17b4051faf5327e44ab774c0d7bd6 /src/CMakeLists.txt
parent7f6306ca964ac5b9245c433e3b688c5d4ee08c35 (diff)
downloadhax-minetest-server-cc64a0405ae0e4025f0b18be3bd0d813cb36fea0.tar.gz
hax-minetest-server-cc64a0405ae0e4025f0b18be3bd0d813cb36fea0.zip
Automatically use SSE registers for FP operations on i386 (#11853)
use SSE for floating-point operations to avoid issues with improper fp-rounding and loss of precision when moving fp-data to incompatible or less-precise registers/storage locations https://gcc.gnu.org/wiki/FloatingPointMath https://gcc.gnu.org/wiki/x87note
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4803b475b..e3389cea9 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -769,6 +769,16 @@ else()
# - we don't deal with Inf/NaN or signed zero
set(MATH_FLAGS "-fno-math-errno -fno-trapping-math -ffinite-math-only -fno-signed-zeros")
+ # Enable SSE for floating point math on 32-bit x86 by default
+ # reasoning see minetest issue #11810 and https://gcc.gnu.org/wiki/FloatingPointMath
+ if(CMAKE_SIZEOF_VOID_P EQUAL 4)
+ check_c_source_compiles("#ifndef __i686__\n#error\n#endif\nint main(){}" IS_I686)
+ if(IS_I686)
+ message(STATUS "Detected Intel x86: using SSE instead of x87 FPU")
+ set(OTHER_FLAGS "${OTHER_FLAGS} -mfpmath=sse -msse")
+ endif()
+ endif()
+
set(CMAKE_CXX_FLAGS_RELEASE "-DNDEBUG ${RELEASE_WARNING_FLAGS} ${WARNING_FLAGS} ${OTHER_FLAGS} -Wall -pipe -funroll-loops")
if(CMAKE_SYSTEM_NAME MATCHES "(Darwin|BSD|DragonFly)")
set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -Os")