aboutsummaryrefslogtreecommitdiff
path: root/src/json/CMakeLists.txt
diff options
context:
space:
mode:
authorproller <proller@github.com>2013-02-22 02:00:44 +0400
committerIlya Zhuravlev <zhuravlevilya@ya.ru>2013-02-22 02:04:53 +0400
commitee07c3f7cf638e854518d2cfcb9c11a64412cc72 (patch)
tree18ecc46deebf58d0a4a6ca93df6a526e2720ae69 /src/json/CMakeLists.txt
parentef6b8bee07b9cefe7d463fabd199548d37ff2bee (diff)
downloadhax-minetest-server-ee07c3f7cf638e854518d2cfcb9c11a64412cc72.tar.gz
hax-minetest-server-ee07c3f7cf638e854518d2cfcb9c11a64412cc72.zip
new auto masterserver
Diffstat (limited to 'src/json/CMakeLists.txt')
-rw-r--r--src/json/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/json/CMakeLists.txt b/src/json/CMakeLists.txt
new file mode 100644
index 000000000..0957799aa
--- /dev/null
+++ b/src/json/CMakeLists.txt
@@ -0,0 +1,14 @@
+if( UNIX )
+ set(json_SRCS jsoncpp.cpp)
+ set(json_platform_LIBS "")
+else( UNIX )
+ set(json_SRCS jsoncpp.cpp)
+ set(json_platform_LIBS "")
+endif( UNIX )
+
+add_library(json ${json_SRCS})
+
+target_link_libraries(
+ json
+ ${json_platform_LIBS}
+)